OverDrive Read and OverDrive Listen Incident
Incident Report for OverDrive
Resolved
This incident has been resolved.
Posted 5 months ago. Mar 08, 2019 - 16:39 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 5 months ago. Mar 08, 2019 - 16:11 EST
Investigating
We are investigating an incident with OverDrive Read and OverDrive Listen resulting in users encountering slow performance, or inability to fully open their books.
Posted 5 months ago. Mar 08, 2019 - 15:40 EST
This incident affected: Reading or listening.