Download issues from OverDrive-hosted websites and the OverDrive app
Incident Report for OverDrive
Resolved
This incident has been resolved and we will continue to monitor.
Posted 6 months ago. Feb 12, 2019 - 11:56 EST
Investigating
Users attempting to download an ebook or audiobook from a library or school OverDrive website or the OverDrive app, may experience an error. This issue does not appear to be impacting downloads through Libby or Sora apps.
Posted 6 months ago. Feb 12, 2019 - 11:55 EST
This incident affected: Downloading.