Intermittent errors in Libby and Sora
Incident Report for OverDrive
Resolved
This incident has been resolved.
Posted Jan 01, 2024 - 23:18 EST
Update
We are continuing to investigate this issue.
Posted Jan 01, 2024 - 22:12 EST
Investigating
Users may experience an error when attempting to borrow, place a hold, or open a book in Libby and Sora.
Posted Jan 01, 2024 - 22:11 EST
This incident affected: Libby and Sora.