OverDrive Read & Listen
Incident Report for OverDrive
Resolved
This incident has been resolved.
Posted Jul 01, 2020 - 12:01 EDT
Identified
An issue has been identified resulting in some users of the Libby and Sora apps being unable to render and read ebooks and audiobooks.
Posted Jul 01, 2020 - 11:53 EDT
This incident affected: Reading or listening.