Users are unable to borrow or place holds

Incident Report for OverDrive

Resolved

This incident has been resolved.
Posted Aug 23, 2026 - 09:18 EDT

Investigating

Users are unable to borrow or place a hold.
Posted Aug 23, 2026 - 09:12 EDT
This incident affected: Libby, Sora, Magazines, and OverDrive Library Sites.