Read and Listen performance issues
Incident Report for OverDrive
Resolved
This incident has been resolved.
Posted Oct 05, 2023 - 17:56 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 05, 2023 - 17:17 EDT
Investigating
We are currently investigating an issue that is causing some users to be unable to access checkouts in Read and Listen formats.
Posted Oct 05, 2023 - 17:04 EDT
This incident affected: Libby, Sora, Magazines, and OverDrive Library Sites.