Recently released content unavailable in OverDrive Read and Listen
Incident Report for OverDrive
Resolved
Availability of content in OverDrive Read and Listen formats has been fixed and these updates will continue to be pushed out to OverDrive systems and apps over the next several hours.
Posted Apr 29, 2024 - 15:00 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 29, 2024 - 11:15 EDT
Identified
We have identified an issue where newly released content is not available in the OverDrive Read and Listen formats. This includes some recently released ebooks, audiobooks, and magazine issues.
Posted Apr 29, 2024 - 09:35 EDT
This incident affected: Libby, Sora, and Magazines.