Read and Listen Incident
Incident Report for OverDrive
Resolved
From 9:46-10:37 PM US Eastern Time, users were unable to download ebooks and audiobooks in Libby, Sora, or via a browser using OverDrive Read or Listen. This issue is now resolved and we apologize for the inconvenience.
Posted Sep 14, 2019 - 22:42 EDT
Investigating
We are currently investigating an incident with OverDrive Read and Listen fulfillment.
Posted Sep 14, 2019 - 22:16 EDT
This incident affected: Reading or listening.