Libby app experiencing issues
Incident Report for OverDrive
Resolved
This incident has been resolved.
Posted May 21, 2020 - 11:40 EDT
Identified
Some Libby users are getting error messages when they try to use the app, many Libby users will see a blank screen with “RETRY” on it or a 504 error.
Posted May 21, 2020 - 11:28 EDT
This incident affected: Browsing and searching.