Press Reader users cannot access the service

Incident Report for OverDrive

Resolved

This incident has been verified to have not been impacting multiple libraries and is now resolved. We will continue to troubleshoot any Press Reader access issues with impacted customers directly.
Posted Mar 27, 2025 - 15:40 EDT

Investigating

We are investigating an incident where users are unable to access Press Reader (an Extra via Libby).
Posted Mar 27, 2025 - 10:24 EDT
This incident affected: Extras (Databases & Streaming Media).