Audiobook and ebook loading issues
Incident Report for OverDrive
Resolved
Audiobooks and ebooks in the Libby and Sora apps, as well as in a web browser, are now loading as expected. We apologize for the disruption and appreciate your patience.
Posted 11 months ago. Sep 10, 2018 - 15:25 EDT
Investigating
Audiobooks and ebooks in the Libby and Sora apps, as well as in a web browser, are not loading properly. When a user clicks on a title, it will spin and eventually fail to load. This issue is also affecting audiobook and ebook samples. We are working to resolve this issue as quickly as possible.
Posted 11 months ago. Sep 10, 2018 - 14:57 EDT
This incident affected: Reading or listening.