Error message when accessing Databases & Streaming Media Services
Incident Report for OverDrive
Resolved
This incident has been resolved.
Posted May 26, 2021 - 09:15 EDT
Investigating
Some users attempting to access Databases & Streaming Media services from OverDrive may receive an error message.
Posted May 21, 2021 - 09:56 EDT
This incident affected: Databases & Streaming Media Services (external).