Marketplace performance degradation
Incident Report for OverDrive
Resolved
Marketplace performance has remained stable and this incident is now resolved.
Posted Oct 13, 2020 - 20:47 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 13, 2020 - 15:52 EDT
Identified
We have identified an issue that is resulting in slowness, timeouts, and related errors in Marketplace and are working to return performance to normal.
Posted Oct 13, 2020 - 15:34 EDT
This incident affected: OverDrive Marketplace.