Issue affecting Libby app
Incident Report for OverDrive
Resolved
This incident has been resolved.
Posted 5 days ago. Aug 13, 2019 - 17:29 EDT
Update
We are continuing to work on a fix for this issue.
Posted 5 days ago. Aug 13, 2019 - 17:29 EDT
Identified
We're aware of an issue affecting libbyapp.com that may be causing Libby to fail to load. This is potentially affecting new Libby users both in app and in browsers.
Posted 5 days ago. Aug 13, 2019 - 17:23 EDT
This incident affected: Browsing and searching and Reading or listening.