Streaming Video playback is down
Incident Report for OverDrive
Resolved
This incident has been resolved.
Posted Mar 11, 2020 - 20:24 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 11, 2020 - 19:56 EDT
Update
We are continuing to work on a fix for this issue.
Posted Mar 11, 2020 - 19:17 EDT
Update
A portion of the streaming video cataloging is now playing as expected. We are continuing to resolve playback issues for the remaining titles still impacted by this incident.
Posted Mar 11, 2020 - 18:21 EDT
Update
We are continuing to work on a fix for this issue.
Posted Mar 11, 2020 - 17:24 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 11, 2020 - 17:11 EDT
Investigating
We are currently investigating an issue with OverDrive Streaming Video playback.
Posted Mar 11, 2020 - 16:14 EDT
This incident affected: Reading or listening.