eBook and Audiobook outage
Incident Report for OverDrive
Resolved
This incident has been resolved.
Posted Sep 14, 2020 - 12:24 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 14, 2020 - 12:16 EDT
Identified
Libby and OverDrive websites and fulfillment of eBook and audiobooks are experiencing issues. This may also impact features like notes/highlights.
Posted Sep 14, 2020 - 11:42 EDT