OverDrive Service Outage
Incident Report for OverDrive
Resolved
This incident has been resolved.
Posted Jun 13, 2020 - 19:30 EDT
Update
We are continuing to investigate this issue.
Posted Jun 13, 2020 - 19:30 EDT
Investigating
We are currently investigating this issue.
Posted Jun 13, 2020 - 17:58 EDT
This incident affected: Signing in, Downloading, and Reading or listening.