OverDrive Service Outage
Incident Report for OverDrive
Resolved
This incident has been resolved and we are continuing to monitor.
Posted Jun 16, 2020 - 00:36 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 16, 2020 - 00:28 EDT
Investigating
We are currently investigating this issue.
Posted Jun 15, 2020 - 23:42 EDT
This incident affected: Browsing and searching, Signing in, Downloading, and Reading or listening.