Libby partial outage
Incident Report for OverDrive
Resolved
This incident has been resolved.
Posted Nov 07, 2024 - 20:54 EST
Identified
A partial outage is affecting several Libby including checkouts and holds may be failing for many users, and users may be unable to open loans or samples unless the loan is downloaded.
Posted Nov 07, 2024 - 20:22 EST
This incident affected: Libby.