Streaming Video playback error
Incident Report for OverDrive
Resolved
This incident has been resolved. We apologize for the inconvenience.
Posted Apr 29, 2020 - 08:47 EDT
Identified
Streaming video playback is currently unavailable. Users attempting to play video are receiving an error.
Posted Apr 29, 2020 - 06:30 EDT
This incident affected: Downloading.