OverDrive performance issues
Incident Report for OverDrive
Resolved
This incident has been resolved.
Posted 11 months ago. Nov 16, 2018 - 14:09 EST
Monitoring
A fix has been implemented and we will continue to monitor.
Posted 11 months ago. Nov 16, 2018 - 13:14 EST
Investigating
Users of your digital library website, and the Libby and Sora apps, are experiencing issues such as slow loading, errors, or timeouts when browsing, searching, or attempting to download a title. We are working as quickly as possible to resolve these issues.
Posted 11 months ago. Nov 16, 2018 - 12:24 EST