Kindle Book fulfillment issue (U.S. only)
Incident Report for OverDrive
Resolved
The Kindle fulfillment issue that some users may have experienced has been resolved.
Posted about 2 months ago. Jun 28, 2019 - 10:34 EDT
Identified
Users attempting to download a Kindle Book may experience page display issues at Amazon’s website. This is preventing some users from being able to download and access Kindle Books. We have reported the issue to Amazon and will provide an update when it is resolved.
Posted about 2 months ago. Jun 27, 2019 - 13:25 EDT
This incident affected: Downloading.