Some users are unable to view cover images or play OverDrive Listen audiobooks in Libby, Sora, Marketplace, OverDrive websites

Incident Report for OverDrive

Resolved

This incident has been resolved.
Posted Jan 03, 2025 - 17:11 EST

Update

We are continuing to investigate this issue.
Posted Jan 03, 2025 - 16:12 EST

Investigating

We are currently investigating this issue.
Posted Jan 03, 2025 - 15:36 EST
This incident affected: Libby, Sora, Magazines, OverDrive Library Sites, and OverDrive Marketplace.