indieFlix (Libby Extra): users cannot access the service
Incident Report for OverDrive
Resolved
This incident has been resolved.
Posted Jul 26, 2024 - 11:27 EDT
Investigating
We are currently working with the vendor to identify and resolve this issue.
Posted Jul 17, 2024 - 11:41 EDT
This incident affected: Extras (Databases & Streaming Media).