Some users may experience time outs or errors
Incident Report for OverDrive
Resolved
This incident has been resolved.
Posted Aug 31, 2019 - 11:40 EDT
Identified
A small percentage of users may experience timeouts and errors trying to checkout books or open books.
Posted Aug 31, 2019 - 10:02 EDT
This incident affected: Downloading and Reading or listening.