LawDepot (Libby Extra): users cannot access the service
Incident Report for OverDrive
Resolved
This incident is now resolved.
Posted Jul 17, 2024 - 14:48 EDT
Monitoring
A fix has been implemented by the vendor and we are monitoring results.
Posted Jul 17, 2024 - 11:32 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 16, 2024 - 15:40 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 15, 2024 - 09:25 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 10, 2024 - 13:52 EDT
This incident affected: Extras (Databases & Streaming Media).