Delay to collection updates and title availability
Incident Report for OverDrive
Resolved
This incident has been resolved.
Posted Nov 08, 2023 - 16:29 EST
Identified
We have identified a delay to collection updates and title availability preventing users from discovering and checking out some newly purchased or released content. We are working to resolve this delay so that collections are again up to date.
Posted Nov 08, 2023 - 13:32 EST
This incident affected: Libby, Sora, and OverDrive Library Sites.