EZproxy authentication outage
Incident Report for OverDrive
Resolved
This incident has been resolved. We apologize for the inconvenience and appreciate your patience.
Posted Jul 16, 2020 - 15:37 EDT
Investigating
We are currently experiencing an issue loading the external sites from EZproxy, so users attempting to sign in on these sites are not able to access the sign in page.
Posted Jul 16, 2020 - 12:09 EDT
This incident affected: Signing in.