OverDrive Marketplace outage
Incident Report for OverDrive
Resolved
This issue has been resolved. The outage was from 8:48-9:10 AM. We will continue to monitor.
Posted 4 months ago. Apr 26, 2019 - 09:25 EDT
Investigating
OverDrive Marketplace is currently experiencing an outage. Our team is investigating and will provide more information when it's available. Note: This does not impact the end user experience.
Posted 4 months ago. Apr 26, 2019 - 09:10 EDT
This incident affected: OverDrive Marketplace.