Read and Listen impacted by AWS Incident
Incident Report for OverDrive
Resolved
This incident has been resolved.
Posted Oct 23, 2019 - 05:50 EDT
Update
We've observed stable service to OverDrive Read and Listen and will continue to monitor until Amazon fully closes their incident.
Posted Oct 22, 2019 - 22:15 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 22, 2019 - 21:36 EDT
Identified
OverDrive Read and Listen are currently experiencing issues loading content due to an incident with Amazon Web Services. We are attempting to mitigate and monitor this issue as Amazon works to resolve the incident.
Posted Oct 22, 2019 - 21:18 EDT
This incident affected: Reading or listening.