OverDrive Service Outage
Incident Report for OverDrive
Resolved
This incident has been resolved. The incident resulted in roughly 15 minutes of service interruption beginning at 11:30 AM Eastern.
Posted Feb 20, 2020 - 11:50 EST
Identified
We have identified an issue resulting in outage with several OverDrive services and are working to resolve this incident as a priority.
Posted Feb 20, 2020 - 11:47 EST
This incident affected: Browsing and searching, Signing in, Downloading, Reading or listening, and OverDrive Marketplace.