Interruption with downloading OverDrive MP3 Audiobooks
Incident Report for OverDrive
Resolved
This incident has been resolved.
Posted Sep 20, 2019 - 17:48 EDT
Monitoring
Downloading services are returning to expected operations and we will be continuing to monitor. This incident has been found to impact additional downloadable formats, such as epub.
Posted Sep 20, 2019 - 17:17 EDT
Investigating
We are currently investigating an interruption in the ability to download OverDrive MP3 audiobooks. this incident is not believed to be impacting audiobooks in OverDrive Listen, Libby or Sora.
Posted Sep 20, 2019 - 16:59 EDT
This incident affected: Downloading.