New issues of Magazines are unavailable

Incident Report for OverDrive

Resolved

This incident has been resolved.
Posted Jul 03, 2025 - 10:34 EDT

Update

A fix for this issue is currently in progress. We will be monitoring and provide an update once a resolution has been confirmed to be fully in place.
Posted Jul 03, 2025 - 08:43 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 03, 2025 - 08:25 EDT

Investigating

We are currently investigating an issue where the most recently released issues of Magazines are unavailable to be opened or checked out by end users.
Posted Jul 03, 2025 - 08:01 EDT
This incident affected: Magazines.