Incident with OverDrive Read and OverDrive Listen
Incident Report for OverDrive
Resolved
This incident has been resolved.
Posted 4 months ago. May 02, 2019 - 17:25 EDT
Monitoring
Performance across OverDrive services has improved and we will will continue to monitor.
Posted 4 months ago. May 02, 2019 - 17:04 EDT
Update
This incident is impacting several OverDrive services, resulting in some performance degradation in OverDrive websites and apps, including Libby and Sora. We are working to minimize impact and resolve the issue as soon as possible.
Posted 4 months ago. May 02, 2019 - 16:47 EDT
Identified
We have identified an issue when users attempt to open book though OverDrive Read and OverDrive Listen, or to read a sample of a book. This issue is not believed to impacting users of the Libby or Sora apps.
Posted 4 months ago. May 02, 2019 - 16:29 EDT
This incident affected: Browsing and searching and Reading or listening.