Sora outage

Incident Report for OverDrive

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 20:54 EDT

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 11:56 EDT

Monitoring

This issue has been resolved and we will continue to monitor.
Posted Oct 20, 2025 - 11:53 EDT

Identified

Users may experience issues with borrowing, downloading, and opening books in Sora.
Posted Oct 20, 2025 - 09:21 EDT
This incident affected: Sora.