Kindle users are unable to send books to their device
Incident Report for OverDrive
Resolved
This issue was resolved as of 7:35 PM US ET. We apologize for the disruption.
Posted Sep 19, 2018 - 20:48 EDT
Identified
When a user attempts to send a book to their Kindle device, they are directed to an Amazon page that does not have the option to send to a device. We are working as quickly as possible to resolve this issue. Note: Kindle books are available to U.S. partners only.
Posted Sep 19, 2018 - 18:29 EDT
This incident affected: Downloading.