Curated Lists displaying partial results
Incident Report for OverDrive
Resolved
The resolution for Curated Lists is now in place across all libraries, and all titles in a Curated List will display to users.
Posted 12 months ago. Aug 31, 2018 - 15:59 EDT
Identified
Beginning this morning, August 31, not all titles assigned to a Curated List are appearing, resulting in a partial list displaying. This behavior will occur on your OverDrive website, and from within the OverDrive, Libby, and Sora apps.

This issue is in the process of being fixed, and we expect a full resolution across all websites by 5 PM Eastern Time today.
Posted 12 months ago. Aug 31, 2018 - 10:57 EDT
This incident affected: Browsing and searching.