OverDrive Service Outage
Incident Report for OverDrive
Resolved
OverDrive services are now restored. As a result of this outage Libby users may have temporarily lost their Library information, such as card information and current loans. This information should be restored automatically.

We again apologize for the disruption and appreciate your support and patience as we worked to implement a fix.
Posted Apr 17, 2020 - 22:59 EDT
Monitoring
We have implemented a fix and are confirming the impact to various OverDrive services.
Posted Apr 17, 2020 - 22:24 EDT
Update
We continue to appreciate your patience as we work on restoring service. Our teams have begun working on alternative solutions in an attempt to restore some functionality while we continue investigate and fix the original service outage.
Posted Apr 17, 2020 - 21:51 EDT
Update
Our teams have identified a faulty component of our network that is resulting in tonight's outage. We are investigating possible remedies so that service can be restored as soon as possible.
Posted Apr 17, 2020 - 21:20 EDT
Update
We are continuing to work on a fix for this outage and appreciate your patience as we work on a resolution.
Posted Apr 17, 2020 - 20:51 EDT
Update
Our teams are continuing to work a resolution for this outage with utmost priority. We apologize for the disruption and will continue to provide regular updates on the status of this outage.
Posted Apr 17, 2020 - 20:21 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 17, 2020 - 19:52 EDT
Investigating
We are currently investigating an issue resulting in many OverDrive products and services being inaccessible.
Posted Apr 17, 2020 - 19:18 EDT
This incident affected: Browsing and searching, Signing in, Downloading, Reading or listening, and OverDrive Marketplace.