Some OverDrive Websites Inaccessible
Incident Report for OverDrive
Resolved
This incident has been resolved.
Posted 3 months ago. Aug 01, 2019 - 11:59 EDT
Identified
Some OverDrive websites that are informational or provide support to Library and end-user services are currently inaccessible. This incident is not impacting primary library services such as discover, authentication, checkouts, or downloads.
Posted 3 months ago. Aug 01, 2019 - 11:56 EDT