OverDrive Service Outage
Incident Report for OverDrive
Resolved
This incident has been resolved.
Posted Sep 19, 2020 - 17:17 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 19, 2020 - 17:08 EDT
Update
We are currently implementing a mitigation solution for the current service outage and will update once we have confirmed services are restored.
Posted Sep 19, 2020 - 16:13 EDT
Update
We are continuing to work on a fix for this issue.
Posted Sep 19, 2020 - 15:57 EDT
Identified
The issue has been identified and our team is working on a mitigation or fix to restore services.
Posted Sep 19, 2020 - 15:32 EDT
Update
We are continuing to investigate this issue.
Posted Sep 19, 2020 - 15:26 EDT
Investigating
We are currently investigating an issue resulting in an outage to OverDrive services.
Posted Sep 19, 2020 - 15:19 EDT
This incident affected: Libby, Sora, and Kanopy.