Performance issues in OverDrive Marketplace
Incident Report for OverDrive
Resolved
This incident has been resolved.
Posted Jan 07, 2021 - 12:33 EST
Update
We are continuing to fix this issue, however several functions of Marketplace have had service restored and the majority of users should experience improved performance.
Posted Jan 07, 2021 - 09:38 EST
Identified
We have identified an issue resulting in a performance impact to OverDrive Marketplace. Users may encounter an error when attempting to log in to Marketplace, or may encounter unexpected behavior while attempting to use search and other features.
Posted Jan 07, 2021 - 08:47 EST
This incident affected: OverDrive Marketplace.