OverDrive Performance Issue
Incident Report for OverDrive
Resolved
This incident has been resolved. OverDrive services resumed normal performance levels for users starting at 12:20 PM.
Posted May 09, 2022 - 12:44 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 09, 2022 - 12:32 EDT
Update
We are continuing to work on a fix for this issue.
Posted May 09, 2022 - 12:18 EDT
Identified
We have identified an incident resulting in reduced performance at OverDrive websites and services.
Posted May 09, 2022 - 12:14 EDT
This incident affected: Browsing and searching, Signing in, Downloading, and Reading or listening.