OverDrive Read and OverDrive Listen Incident
Incident Report for OverDrive
Resolved
The implemented fix has remained stable and this incident is now resolved.
Posted Apr 23, 2019 - 20:18 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 23, 2019 - 18:02 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 23, 2019 - 17:12 EDT
Investigating
We are currently investigating an issue with OverDrive Read and OverDrive Listen titles not opening for some users.
Posted Apr 23, 2019 - 17:01 EDT
This incident affected: Reading or listening.