OverDrive Service Outage
Incident Report for OverDrive
Resolved
Maintenance has completed and OverDrive services have been restored.
Posted Sep 19, 2020 - 21:15 EDT
Identified
We have identified the issue resulting in the OverDrive service outage and we are performing urgent manitnenace to alleviate and resolve the issue.
Posted Sep 19, 2020 - 20:58 EDT
This incident affected: Libby, Sora, and Kanopy.